一级域名绑定二级目录伪静态 和 二级目录wordpress伪静态规则写法

这LNMP下,原wordpress伪静态的写法:

location / {
if (-f $request_filename/index.html){
rewrite (.*) $1/index.html break;
}

if (-f $request_filename/index.php){
rewrite (.*) $1/index.php;
}

if (!-f $request_filename){
rewrite (.*) /index.php;
}
}
如果需要一级域名绑定到二级目录,如www.7966.org 绑定到 www.7966.org/blog这个目录,

调用上面写法就出问题了,必须写一个新的伪静态才行,很简单:
location / {
if (-f $request_filename/二级目录/index.html){
rewrite (.*) $1/二级目录/index.html break;
}
if (-f $request_filename/二级目录/index.php){
rewrite (.*) $1/二级目录/index.php;
}
if (!-f $request_filename){
rewrite (.*) /二级目录/index.php;
}
}
当出现报错,估计是rewrite写得不规范,例如:nginx: [emerg] invalid number of arguments in "rewrite" ...

必须看看上面的规则是否有空格的地方没有空格这个必须注意!

 如果一级目录需要放其他东西,而二级目录放博客的话,实现wordpress伪静态,其实也很简单的

例如:www.7966.org是放置CMS,而二级目录blog放博客,且要这个博客实现伪静态的话,

调用原来的文件,会出现404的,那么需要重新建一个wordpress2.conf,内容如下
location /blog/ {
if (-f $request_filename/index.html){
rewrite (.*) $1/index.html break;
}

if (-f $request_filename/index.php){
rewrite (.*) $1/index.php;
}

if (!-f $request_filename){
rewrite (.*) /blog/index.php;
}
}
这样就基本搞定了,不过不要忘记把/usr/local/nginx/conf/vhost

下面www.7966.org.conf 里面的伪静态修改为wordpress2.conf

版权所有,作者:老钟,如若转载,请注明出处:https://www.laoz.net/306.html

赞 (1)
老钟
上一篇 2012 年 11 月 29 日 下午 6:56
下一篇 2013 年 08 月 02 日 下午 6:05

相关推荐

  • 解决lnmp 1.2,lnmp 1.3无法远程连接数据库

    安装了lnmp 1.2之后的版本,发现远程连接mysql总是失败,原本以为是设置的问题,后来才发现原来是lnmp中iptables的规则问题 首先先要确定自己的设置是没有问题的,访问数据库的用户使用的是%权限 如果设置没问题,…

    vps教程 2016 年 08 月 18 日
  • 新建VPS服务器的安全防护设置

    0x00 起因 最近我自己的 vps 越来越不稳定,开始还以为是因为我自己在路由器里面添加了透明代理使用的流量大造成的,后来越来越发觉不正常,毕竟我也是用了几年 vps 的老手了,总觉的不正常。后来 iftop 发现我的 v…

    vps教程 2020 年 05 月 04 日
  • linux 安装完 jdk1.5 ,出现 java.lang.NoClassDefFoundError: com/sun/tools/javac/Main

    安装完jdk后,java -version 能现实版本,但是运行java程序就出现问题,例如 javac a.java 的时候,出现 Exception in thread "main" java.lang.NoClassDefFoundError: com/sun/tools/javac/Main 原因是jdk目录下面…

    vps教程 2011 年 11 月 25 日
  • 目前我在工作中常用的linux命令

    top   看cpu  内存  程序是否运行 c   显示命令路径 ctrl + c    终止 q   终止 空格  自动刷新 pwd    当前所在目录 ll   查看所有文件   (文件权限  所有者) ll * | grep  aa    查看aa文件 ls    查看所有文件…

    vps教程 2011 年 08 月 17 日
  • Linux下搭建php运行环境【转】

    需要安装的软件: 1. 安装mysql 1.1安装编译器gcc 最小化安装,没有安装编译器 yum install gcc yum install gcc-c++ 如果不安装,在编译mysql的时候会出现【exec: g++: not found】错误 1.2安装ncurses-5.6.tar…

    vps教程 2011 年 08 月 16 日
  • Rockylinux8/Almalinux8 安装lnmp一键安装包

    由于centos停更,很多云服务器服务商不支持centos7或者centos8,所以打算装个Rockylinux或者Almalinux玩玩。 当然,为了省事方便,选用军哥的lnmp一键安装包; 安装的时候发现因为openssl的版本,导致了lnmp安装失…

    2025 年 12 月 11 日
  • linux定时任务

    例子   每天早上6点 0 6 * * * echo "Good morning." >> /tmp/test.txt //注意单纯echo,从屏幕上看不到任何输出,因为cron把任何输出都email到root的信箱了。 每两个小时 0 */2 * * * echo "Have a bre…

    vps教程 2011 年 08 月 29 日
  • lnmp安装阿里云免费SSL,出现welcome to nginx页面,提示403错误解决办法

    lnmp安装阿里云免费SSL 申请的时候要注意如下: 保护一个明细域名,例如: buy.example.com,或next.buy.example.com, 各个明细子域名都算一个域名 本机环境使用lnmp服务,需要修改nginx的内容 阿里云官方提供的设置办…

    vps教程 2017 年 09 月 28 日
  • 硬盘安装redhat 6.5图文教程 linux rhel-server-6.5安装

    硬盘安装redhat    硬盘安装linux redhat有很多版本,我安装在一台台式电脑上面,这台电脑原来在使用的,内存4G,可以全盘格式化再安装,不过我装了双系统,即win7和linux 首先第一步,下载redhat 6.5的ISO镜像,我…

    2016 年 08 月 16 日
  • centos7 vps服务器的安全设置

    大家都知道centOS7以上的跟centOS6在命令是有很大变化的,未来也是趋势 老钟博客之前服务器安全的分析均是在CentOS6基础上进行,因为习惯了,一般不喜欢去更换系统 但是CentOS7以上基础安全性和运行效果是更加好 那…

    vps教程 2020 年 07 月 03 日